1) I updated XCODE app to the 13.3 version and installed the suggested Command Tools. I use the MacOS Terminal app with the default configuration, so the default shell is 'zsh'. Here is the contents of my .zprofile profile file in /Users/alberto, where I added the export command for every Eiffel environment variable: # MacPorts Installer addition on 2021-09-05_at_19:26:19: adding an appropriate PATH variable for use with MacPorts. export PATH="/opt/local/bin:/opt/local/sbin:$PATH" # Finished adapting your PATH environment variable for use with MacPorts. # --- Adding appropriate variables for use with Eiffel in /Users/alberto/Eiffel_21.11. export ISE_EIFFEL=/Users/alberto/Eiffel_21.11 export ISE_PLATFORM=macosx-x86-64 export PATH=$PATH:$ISE_EIFFEL/studio/spec/$ISE_PLATFORM/bin # --- Finished adapting variables for use with Eiffel in /Users/alberto/Eiffel_21.11. 2) As suggested in Eiffel MacOS Setup and Installation instructions, in the Starting EiffelStudio section: ----> 'Now everything should be properly installed and you should be able to run the compiler. Simply navigate to /Applications/MacPorts/EiffelXX and double click the EiffelStudio icon. Alternatively, you can also start EiffelStudio from the command line by entering the command 'estudio' or use the command-line eiffel compiler 'ec'. ?? I have no EiffelXX folder and no EiffelStudio icon or application in /Applications/MacPorts folder. I don't know why and if there is a way to obtain this. 3) I entered in the Terminal window the commands you suggested: sudo launchctl load -w /Library/LaunchDaemons/org.freedesktop.dbus-system.plist launchctl load -w /Library/LaunchAgents/org.freedesktop.dbus-session.plist And no issue: `Dynamic session lookup supported but failed ...` appeared. GREAT! Now I can run 'estudio' in the Terminal window, it correctly opens the Studio app and a panel where I can open the simple.ecf file with 'Compile' ACTION and CLEAN active, as in the Tutorial. In the OUTPUTS TOOL each compilation degree appears: 'Degree 6: Examining System Degree 5: Parsing Classes Degree 4: Analyzing Inheritance Degree 3: Checking Types Degree 2: Generating Byte Code Degree 1: Generating Metadata Melting System Changes Eiffel Compilation Succeeded' 4) When I click the Run button on the toolbar at the top of the EiffelStudio window the following message appears in the popup window: 'You must compile a project first' ?? What can I do now ??